Browse: 🏠 · Solutions · Connectors · Methods · Tables · Content · Parsers · ASIM Parsers · ASIM Products · Logic Apps · 📊
| Attribute | Value |
|---|---|
| Connector ID | VirtualMetricDirectorProxy |
| Publisher | VirtualMetric |
| Used in Solutions | VirtualMetric DataStream |
| Collection Method | Azure Function |
| Connector Definition Files | Template_DirectorProxy.json |
| Ingestion API | HTTP Data Collector API — Connector definition requires workspace key (SharedKey pattern) |
| Microsoft Learn | View on Learn |
VirtualMetric Director Proxy deploys an Azure Function App to securely bridge VirtualMetric DataStream with Azure services including Microsoft Sentinel, Azure Data Explorer, and Azure Storage.
This connector ingests data into the following tables:
| Table | Transformations | Ingestion API | Lake-Only |
|---|---|---|---|
CommonSecurityLog |
✓ | ✓ | ✓ |
💡 Tip: Tables with Ingestion API support allow data ingestion via the Azure Monitor Data Collector API, which also enables custom transformations during ingestion.
Resource Provider Permissions:
Custom Permissions:
⚠️ Note: These instructions were automatically generated from the connector's user interface definition file using AI and may not be fully accurate. Please verify all configuration steps in the Microsoft Sentinel portal.
1. Deploy VirtualMetric Director Proxy
Deploy the Azure Function App that serves as a secure proxy between VirtualMetric DataStream and Microsoft Sentinel. Prerequisites and Deployment Order
Recommended Deployment Order:
For optimal configuration, consider deploying the target connectors first:
Deploy Microsoft Sentinel Connector: Deploy the VirtualMetric DataStream for Microsoft Sentinel connector first to create the required Data Collection Endpoints and Rules.
Deploy Microsoft Sentinel data lake Connector (optional): If using Microsoft Sentinel data lake tables, deploy the VirtualMetric DataStream for Microsoft Sentinel data lake connector.
Deploy Director Proxy (this step): The Director Proxy can then be configured with your Microsoft Sentinel targets.
Note: This order is recommended but not required. You can deploy the Director Proxy independently and configure it with your targets later.
Deploy Azure Function App
Deploy the VirtualMetric Director Proxy Azure Function App using the Deploy to Azure button.
Deploy to Azure:
Configure Deployment Parameters:
Complete Deployment:
https://<function-app-name>.azurewebsites.netConfigure Function App Permissions
Assign the necessary permissions to the Function App's managed identity to access Microsoft Sentinel resources.
Enable System-Assigned Managed Identity:
Navigate to Resource Group:
Assign Required Roles:
Select the Function App Identity:
Get Function App Access Token (Optional for Function Key authentication):
Configure VirtualMetric DataStream Integration
Set up VirtualMetric DataStream to send security telemetry to Microsoft Sentinel through the Director Proxy.
Access VirtualMetric DataStream Configuration:
Configure General Settings:
Configure Azure Authentication:
For Service Principal Authentication:
For Azure Managed Identity:
Configure Director Proxy (in Azure Properties tab):
https://<function-app-name>.azurewebsites.net)Configure Stream Properties:
https://<dce-name>.<region>.ingest.monitor.azure.com)Verify Data Ingestion in Microsoft Sentinel:
CommonSecurityLog
| where TimeGenerated > ago(1h)
| take 10
Browse: 🏠 · Solutions · Connectors · Methods · Tables · Content · Parsers · ASIM Parsers · ASIM Products · Logic Apps · 📊